New: Logitech Touch Mouse Turns Your iPhone or iPod Touch into a Wireless Trackpad and Keyboard

UPDATE: For more info on how to install the Logitech Touch Mouse app, check out our video walkthrough.

iPhone and iPod touch owners: If you haven’t had the chance to check it out, go to the iTunes App Store and download our cool new Touch Mouse app. It turns your iPhone or iPod touch into a wireless trackpad and keyboard for your computer, so you can point, click, scroll and type from afar, in any application, on a Mac or PC.

It works over Wi-Fi, so you can use it anywhere in your house and is a great way to control your computer when it’s connected to your TV and you’re lounging on the couch. And to make typing easier, text is displayed on the screen of your iPhone or iPod touch as you type, so you can see what you’re doing without having to continually look up and down.

And the best part is, the app is free!

Download Touch Mouse in two-steps:
1) Get the Touch Mouse App for your iPhone or iPod touch from the App Store
2) Download Touch Mouse Server software and install it on your computer.

You’ll find instructions when you download the Touch Mouse Server software on Logitech.com.

Once you’re up and running, Touch Mouse will allow you to take advantage of the following features:

  • Multi-touch trackpad with the option for two or three mouse buttons
  • Two-finger scrolling
  • Keyboard with Control, Alt, Command/Windows keys
  • On-screen text display while typing
  • Show or hide the keyboard at any time
  • Trackpad and keyboard are available in landscape and portrait modes

Give it a “scroll” and let us know what you think!

Author

Senior Product Manager, Logitech

382 comments

  • I finally got this stuff working, after searching the web for solutions. At least in my case, the problem was with the firewall. I’ll do my best to outline how I got it working. Be advised, I’m operating TouchMouse under Windows 7 and I’m using the firewall that comes with Windows. Here’s how I got it to work:

    1. Install the TouchMouse server.
    2. Click ‘Start’ and type ‘Firewall’ (without the quotes)
    3. In list of search results you should see ‘Allow a program though Windows Firewall’, click on it.
    4. A new window will appear with a list of current program exceptions. Scroll through the list until you find Logitech. Make sure that both Home/Private and Public check boxes are checked.

    Note: A User Account Control (UAC) diaglog box might appear asking you to authorize these changes.

    That’s it! At least it was for me. These steps should also work (or at least be helpful) for Vista users as well since Vista has a search function built in as well.

    Disclaimer: If you’re not comfortable modifying firewall options, have someone else do it for you.

    I sincerely hope this helps people. :)

  • When I launch the Touch Mouse Server, I get nothing. It looks like it’s trying to open, but it won’t. I am trying to install this on my OS X 10.4.11 I do not believe I have a firewall up either. Anyone have this problem?

  • I installed it this weekend on my laptop running Vista 32-bit. It worked right off the bat, and it performs very well. I have no lag when moving the mouse cursor. One problem I encountered was that every time my Ipod went to sleep it would disconnect itself, and then would not reconnect until I reset the server software on my laptop. I fixed this by simply setting the Ipod to stay awake while the Logitech app is running. Love the app, now I can brows the web comfortably from my couch without having to purchase a new wireless keyboard/mouse setup.

  • Works great on 2 of my Win XP 32 bit systems, but will not work on my Windows 7 64 bit machine. Just as above on all of the other Windows 7 machines, it finds the system and then says it cannot connect.

  • For all those Win 7 users who were not able to connect.
    Try this!!!!!!!!!!!!
    Go to Control Panel and select View By-> Large Icons.
    Choose System and then select Remote Settings from the left hand side nav.
    Select -> Allow connections ….. (less secure)
    Thats it.
    Connect your iPhone over the wifi and enjoy!!!!!!!!
    Just in case if it doesn’t work mail me at yashupadhyay@gmail.com
    This app rocks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  • This is awesome. I installed it on my 2 PC’s last night (Windows 7 x64 and x86) and it runs perfectly. This is the best now one of my favourite appz for iphone/ ipod! and best of all its free!! Great if you loose ur wireless mouse.

  • host is unreachable…What does that mean???? I can not connect and everything that the troubleshooting tells me to do I have done. Why can’t I connect??? May you please help. I also see I am not the only one with this problem so why isn’t there a troubleshoot for this problem?????

  • Love TouchMouse. Downloaded and installed just fine, no connection problems on my Vista32 laptop. Only problem is there needs to be an open window for the mouse to work. Nothing open on the desktop? Gotta walk over to the laptop to open a window for the TouchMouse to do its magic. Hoping this gets fixed in v1.1!

  • I’ve just installed it, i think that this program will be better if i cant see my desktop screen in the iTouch

  • Kenny I had the same problem for a
    while and then it seemed to fix itself…now I can connect and use touchmouse for about 20seconds….then it disconnects itself!!!
    Really frustrating!!

  • Runnin touchmouse1.0_x64 on Win 7 x64, got the app running on my iPod Touch, both wirelessly connected to my home network… Can’t connect. Neither application is aware of the other, and manually entering the IP results in a ‘Connection Failed! Remote host is unreachable.’

    I’ve followed the advice offered by Chuck Norris and Yash above, to no avail — any other tips?

    Must say I find it unusual that the manual suggests you would be able to enable this kind of connection without any kind of security tweaking, prompted or unprompted, on Windows — also unusual that Windows doesn’t come at me with any security prompts when the server attempts to do its thing.

  • I went to the http://www.logitech.com/touchmouse website as directed by Apple today to download the Touch Mouse Server software. I’ve run into a snag, there is no download button to be found on the page. This is after inputting Windows 7 and touchmouse 1.0_x64. exe (64-bit), and the support page was also not helping the situation. Could someone please point me in the right direction.

  • this works great under win 7 but i woukd kike to install the server software as a service instead of having it run on login. the reason being that i logoff my pc whenever im not using it which closes down the server sw, so i cant use my iphone to control the pc until i log in using a regular kb amd mouse. i would also like the keyboard part of the app incorporate the spell checking and shortcut features of the native iphone keyboard

  • Update: I resolved what seemed to be an impasse on my machine by establishing a static IP for my machine. The server couldn’t maintain an open connection from varying auto-assigned IPs.

  • Is there any chance you can add a larger numeric keypad to the app… maybe on a second page, so I can use the itouch to enter numbers into a spreadsheet?

    I love the app…. I gave it four stars… it would be five stars if it had a numeric keypad.

  • host is unreachable…What does that mean???? I can not connect and everything that the troubleshooting tells me to do I have done. Why can’t I connect??? May you please help. I also see I am not the only one with this problem so why isn’t there a troubleshoot for this problem?????

  • great app and it works well on Win 7 Home Premium.

    Would really like to have the arrow keys and ok button as well as tabs, alt tabs like Patrick said above. It would make it perfect to use with Boxee (they have a good remote app for iphone as well) and Windows Media Center. Perfect for a 10 foot interface.

  • We are in March now, do you have any updates on when Canadians will be allowed to try this app? Are there any updates on why Canadians were ignored when the app was first released?

  • Still no sign of this on the Canadian Itunes store….
    Are you holding it back because we took the Gold in Men’s Hockey?

  • works great on ad hoc with laptop. Cannot use because there is not access to the function keys. Presenting software uses function keys to back up or arrow keys. Air mouse has this but your preferences setup is much better and I like the do not sleep option.

    Great first start and looking forward to an update with more features.

    Thank you!
    Chuck

  • it seems like a great app nut it is not working. it connects but does not work as a mouse or a keyboard when i try to control it from my touch.

  • Hay so i’ve been using this app for a lil bit and it works great only one problem is that it doesn’t work with Safari. I’m currently running it on a 32-bit windows vista machine. if any one has a fix to this it would be greatly appreciated.

  • Yes. Canada please! Or at least a declaration as to whether it is going to ever make its way north. I got soooo excited when I first heard about this. I keep checking back just in case. I’m gonna keep my fingers crossed. This sounds so amazing!

  • I ♥ This App!

    Works way better than JumiMouse, which I’ve actually deleted now since that app only had mouse functions (you had to buy the full app for the keyboard to work).

    Not really a big deal for most people, but I use a laptop to stream shows (netflix for example) to my TV in the bedroom. Now I can close the laptop, and use the iPod to control the mouse/keyboard without opening the laptop and mess up my viewing!

  • As of March 9th this is still not available in Canada. What possible excuse is there for not releasing this in Canada? Does it really take over a month to get an app on the Canadian site? Are there legal reasons for this delay or does Logitech just not like Canadians?

  • Hi all,

    Still not working here! Got the app, windows 7 proffesional.
    I do see my pc on my iphone, but i get the: connection failed, host unreachable stuff.

    DID: Chuck Norris > private/public thingy.
    DID: Yash > (less secure) thingy.
    DID: Barney > Static Ip thingy, see pic:http://img40.imageshack.us/img40/2220/staticip.jpg
    the 100 ip is my pc, the 102 is my iphone.

    tried: only Router firewall off.
    tried: only Windows firewall off.
    tried: UPnP enabled..

    dont want to turn both firewall off to make it work, so havent tried that….
    Can someone help me with this one.? :(

  • what a brilliant idea, downloaded the software, installed it and away it went, absolutely mad idea but brilliant :-)
    Also supports turning the ipod on its side so you get a landscape keyboard and touch pad.

  • this is really cool i am using i now i just installed the software and it was working in 30 seconds.

  • So cool !!!

    I can use iPhone to control my Macbook. My iphone became a wireless trackpad :-) You did a great job.

    Thanks

  • Ran into the problem that it couldn’t find my server – either of them. Tried it at my work and home. I’d put in my IP address and it kept saying that the remote host isn’t reachable. mac os x. Coworker was using it fine and thought I’d try it out. Server finder wasn’t helpful either. :-/

  • This app is completely worthless. Doesn’t work on the default settings for Windows 7. Have to do all sorts of manual workarounds to try to fix it, but it still doesn’t work. Complete trash. Stuff like this should work out of the box. The developers who wrote this crap should be ashamed of themeselves.

  • This is a neat trick for using Touch Mouse on a Mac if you just have your computer and iPhone with no wireless network in sight.

    If there is no wireless network, than on your computer go to System Preferences/Sharing and activate Internet Sharing. Select Share your connection from: Built-in Ethernet, then select: To computer using – Airport
    Close window.
    On your iPhone go to Settings, in Wi-Fi find the Network generated by your computer, probably the computer’s name.
    Go to the Touch Mouse app on your iPhone and select the computer.
    Now you can use your iPhone as a remote.

  • WINDOWS & 64 Bit

    The windows 7 version does not set the firewall rules correctly for a Local network.

    Start, then type Firewall into your Search Box
    Left hand Column select Inbound Rules.
    Should be TWO Logiteck Green Ticks Listed.
    Double click on the first one, select the Advanced tab.
    Under Profiles, check the box that says Private.
    Uncheck the box that says Public.
    Click OK.
    Do the same for the other other one and re sync the App.

    Works fine without disabling FireWalls

    Brett

  • “I do not have a firm date, but it should be available in March. Check back here and we’ll let you know when it’s ready.”

    Any Update on Canadian availability? It is the last week of March.

  • I have Windows Vista on 32bit Machine and downloaded the touchmouse app and server software without a hitch.

    The only trouble I have is that when I stop moving the cursor on the screen using the ipod as a touchpad a box pops up as if the right click of a mouse button had been pressed. The grey control box just sits there until the cursor is moved and left button clicked. Then it just pops up wherever the cursor stops again? It is so annoying and really discourages me from using the app.

    If anyone knows how to overcome this I would appreciate it

Comments are closed.